DocumentExport(String, String, ICollectionElementId, SATExportOptions) Method

Exports the current view or a selection of views in SAT format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Export(
	string folder,
	string name,
	ICollection<ElementId> views,
	SATExportOptions options
)

Parameters

folder  String
Output folder, into which file(s) will be exported. The folder must exist.
name  String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
views  ICollectionElementId
Selection of views to be exported. The set must contain at least one valid view.
options  SATExportOptions
Various options applicable to the SAT format.For now, this option is empty. If , all options will be set to their respective default values.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
ExceptionCondition
ArgumentException NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- At least one provided viewId does not correspond to a printable 3D view.
ArgumentNullException A non-optional argument was null
DirectoryNotFoundException Thrown when the directory does not exist.
ForbiddenForDynamicUpdateException This method may not be called during dynamic update.
InvalidOperationException Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException The folder does not exist.
OptionalFunctionalityNotAvailableException The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing.
Remarks
All the views must be 3D views for the Export to succeed.
See Also