SATExportOptions Class

The export options used by exporting SAT format file. So far, there is no option in it.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSATExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SATExportOptions : IDisposable

The SATExportOptions type exposes the following members.

Constructors
 NameDescription
Public methodSATExportOptions Constructs a new instance of SATImportOptions with default values of all properties.
Public methodSATExportOptions(SATExportOptions) Constructs a new instance of SATImportOptions as a copy of the export options.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SATExportOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also