DocumentNewCurtainSystem2 Method |
Creates a new CurtainSystem element from a set of face references.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> NewCurtainSystem2(
ReferenceArray faces,
CurtainSystemType curtainSystemType
)
Public Function NewCurtainSystem2 (
faces As ReferenceArray,
curtainSystemType As CurtainSystemType
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewCurtainSystem2(
ReferenceArray^ faces,
CurtainSystemType^ curtainSystemType
)
member NewCurtainSystem2 :
faces : ReferenceArray *
curtainSystemType : CurtainSystemType -> ICollection<ElementId>
Parameters
- faces ReferenceArray
- The faces new CurtainSystem will be created on.
- curtainSystemType CurtainSystemType
- The Type of CurtainSystem to be created.
Return Value
ICollectionElementId A set of ElementIds of CurtainSystems will be returned when the operation succeeds.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown in following cases:
The input argument faces or curtainSystemType is .
The size of faces is zero.
|
InvalidOperationException |
Thrown when the CurtainSystem cannot be created, for example, the input faces don't
belong to same mass or generic model. Or regenerate fails.
|
ArgumentException | Thrown if the curtain system type does not exist in the given document. |
Remarks The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.
See Also