BRepBuilderEdgeGeometryCreate(Curve) Method |
Construct BRepBuilderEdgeGeometry based on any Revit Curve, including Line and Arc.
The curve will be simplified if possible.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static BRepBuilderEdgeGeometry Create(
Curve curve
)
Public Shared Function Create (
curve As Curve
) As BRepBuilderEdgeGeometry
public:
static BRepBuilderEdgeGeometry^ Create(
Curve^ curve
)
static member Create :
curve : Curve -> BRepBuilderEdgeGeometry
Parameters
- curve Curve
-
The 3D curve for this edge. This BRepBuilderEdgeGeometry stores a copy of the input curve.
Return Value
BRepBuilderEdgeGeometry
ExceptionsException | Condition |
---|
ArgumentException |
The input curve is not bound.
-or-
The curve is degenerate (its length is too close to zero).
-or-
The endpoints of the curve are close enough that Revit considers it a closed curve.
|
ArgumentNullException |
A non-optional argument was null
|
See Also