BRepBuilderEdgeGeometry Class

An abstract class used by BRepBuilder to represent the geometry of an edge. Specific edge-geometry representations are represented by subclasses.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBRepBuilderEdgeGeometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BRepBuilderEdgeGeometry : IDisposable

The BRepBuilderEdgeGeometry type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodStatic memberCreate(Curve) Construct BRepBuilderEdgeGeometry based on any Revit Curve, including Line and Arc. The curve will be simplified if possible.
Public methodStatic memberCreate(XYZ, XYZ) Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.
Public methodDisposeReleases all resources used by the BRepBuilderEdgeGeometry
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also