ApplicationNewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) Method |
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstanceCreationData NewFamilyInstanceCreationData(
XYZ location,
FamilySymbol symbol,
StructuralType structuralType
)
Public Function NewFamilyInstanceCreationData (
location As XYZ,
symbol As FamilySymbol,
structuralType As StructuralType
) As FamilyInstanceCreationData
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
XYZ^ location,
FamilySymbol^ symbol,
StructuralType structuralType
)
member NewFamilyInstanceCreationData :
location : XYZ *
symbol : FamilySymbol *
structuralType : StructuralType -> FamilyInstanceCreationData
Parameters
- location XYZ
- The physical location where the instance is to be placed.
- symbol FamilySymbol
- A FamilySymbol object that represents the type of the instance that is to be inserted.
- structuralType StructuralType
- Specify if the family instance is structural.
Return Value
FamilyInstanceCreationData
See Also