RebarShapeDefinitionByArcAddConstraintDiameter Method |
Specify a parameter to drive the diameter of the shape.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddConstraintDiameter(
ElementId paramId,
RebarShapeArcReferenceType arcRefType
)
Public Sub AddConstraintDiameter (
paramId As ElementId,
arcRefType As RebarShapeArcReferenceType
)
public:
void AddConstraintDiameter(
ElementId^ paramId,
RebarShapeArcReferenceType arcRefType
)
member AddConstraintDiameter :
paramId : ElementId *
arcRefType : RebarShapeArcReferenceType -> unit
Parameters
- paramId ElementId
-
Id of a parameter to drive the constraint.
To obtain the id of a shared parameter,
call RebarShape.GetElementIdForExternalDefinition().
- arcRefType RebarShapeArcReferenceType
-
Specify how the diameter should be measured--to the interior of the bend, the centerline of the bar, or the exterior.
Exceptions
See Also