RebarShapeArcReferenceType Enumeration |
A Rebar Shape Definition constraint that is
measured to a bend must take the bar diameter into
account by specifying whether it measures to
the exterior, centerline, or interior of the bend.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum RebarShapeArcReferenceType
Public Enumeration RebarShapeArcReferenceType
public enum class RebarShapeArcReferenceType
type RebarShapeArcReferenceType
MembersMember name | Value | Description |
---|
Centerline | 0 |
Measure to the centerline of the bar.
|
External | 1 |
Measure to the exterior of the bend.
|
Internal | -1 |
Measure to the interior of the bend.
|
See Also