LoadedFamilyIntegrityCheckCheckAllFamiliesSlow Method |
Check integrity of content documents of all families loaded in the host document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool CheckAllFamiliesSlow(
Document ADoc,
ISet<ElementId> corruptFamilyIds
)
Public Shared Function CheckAllFamiliesSlow (
ADoc As Document,
corruptFamilyIds As ISet(Of ElementId)
) As Boolean
public:
static bool CheckAllFamiliesSlow(
Document^ ADoc,
ISet<ElementId^>^ corruptFamilyIds
)
static member CheckAllFamiliesSlow :
ADoc : Document *
corruptFamilyIds : ISet<ElementId> -> bool
Parameters
- ADoc Document
-
The host document.
- corruptFamilyIds ISetElementId
-
Return ids of families that need to be reloaded because their content documents are missing or corrupt.
Return Value
Boolean
Returns true if all content documents are usable.
Exceptions
Remarks
This check is slow as it invloves traversal of all content documents.
It also dumps data about bad families into the journal, as well as the whole content tree into the dump file.
See Also