TopographySurfaceMaterialId Property

The id of the material applied to this element.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId MaterialId { get; set; }

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentException When setting this property: The materialId cannot map to a valid material element.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
This applies to TopographySurface and SiteSubRegion elements.
See Also