DocumentNewRooms2(Phase, Int32) Method |
Creates new unplaced rooms in the given phase.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> NewRooms2(
Phase phase,
int count
)
Public Function NewRooms2 (
phase As Phase,
count As Integer
) As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ NewRooms2(
Phase^ phase,
int count
)
member NewRooms2 :
phase : Phase *
count : int -> ICollection<ElementId>
Parameters
- phase Phase
- The phase on which the rooms are to exist.
- count Int32
- The number of the rooms to be created.
Return Value
ICollectionElementId If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.
ExceptionsException | Condition |
---|
InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the creation. |
ArgumentException | Thrown if the phase does not exist in the given document. |
See Also