DocumentNewExtrusionRoof Method |
Creates a new Extrusion Roof.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExtrusionRoof NewExtrusionRoof(
CurveArray profile,
ReferencePlane refPlane,
Level level,
RoofType roofType,
double extrusionStart,
double extrusionEnd
)
Public Function NewExtrusionRoof (
profile As CurveArray,
refPlane As ReferencePlane,
level As Level,
roofType As RoofType,
extrusionStart As Double,
extrusionEnd As Double
) As ExtrusionRoof
public:
ExtrusionRoof^ NewExtrusionRoof(
CurveArray^ profile,
ReferencePlane^ refPlane,
Level^ level,
RoofType^ roofType,
double extrusionStart,
double extrusionEnd
)
member NewExtrusionRoof :
profile : CurveArray *
refPlane : ReferencePlane *
level : Level *
roofType : RoofType *
extrusionStart : float *
extrusionEnd : float -> ExtrusionRoof
Parameters
- profile CurveArray
- The profile of the extrusion roof. The curves of the profile must be contiguous and form one open loop without self-intersections. The profile curves must lie in the %refPlane% parallel to z-axis.
- refPlane ReferencePlane
- The work plane for the extrusion roof. It must be parallel to z-axis.
- level Level
- The level of the extrusion roof.
- roofType RoofType
- Type of the extrusion roof.
- extrusionStart Double
- Start the extrusion. Measured from %refPlane% in the direction of the plane normal.
- extrusionEnd Double
- End the extrusion. Measured from %refPlane% in the direction of the plane normal.
Return Value
ExtrusionRoof
Exceptions
Remarks This method will regenerate the document even in manual regeneration mode.
See Also