AnalyticalMemberSplit Method |
Splits the analytical member at a point on its defining curve.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId Split(
double parameter
)
Public Function Split (
parameter As Double
) As ElementId
public:
ElementId^ Split(
double parameter
)
member Split :
parameter : float -> ElementId
Parameters
- parameter Double
-
The normalized parameter value along the element (should be greater than 0 and less than 1).
Return Value
ElementId
The newly created analytical member id.
Exceptions
Remarks
Analytical members that are not a line or an arc are not permitted.
See
CanSplit to determine if the analytical member is allowed to be split by this method.
See Also