DeleteElementsCreate(Document, ISetElementId) Method

Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static FailureResolution Create(
	Document document,
	ISet<ElementId> ids
)

Parameters

document  Document
The document which owns the elements to delete.
ids  ISetElementId
The ids of the elements that will be deleted when this resolution is chosen.

Return Value

FailureResolution
The instance of the DeleteElements resolution.
Exceptions
ExceptionCondition
ArgumentException The input ids is empty or contains an invalid element id.
ArgumentNullException A non-optional argument was null
See Also