DeleteElements Class

Deletes element(s) related to the failure.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFailureResolution
    Autodesk.Revit.DBDeleteElements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DeleteElements : FailureResolution

The DeleteElements type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FailureResolution)
Top
Methods
 NameDescription
Public methodStatic memberCreate(Document, ElementId) Creates an instance of the DeleteElements resolution.
Public methodStatic memberCreate(Document, IListElementId) Creates an instance of the DeleteElements resolution.
Public methodStatic memberCreate(Document, ISetElementId) Creates an instance of the DeleteElements resolution.
Public methodDispose
(Inherited from FailureResolution)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also