DocumentNewRoomBoundaryLines Method |
Creates a new boundary line as an Room border.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ModelCurveArray NewRoomBoundaryLines(
SketchPlane sketchPlane,
CurveArray curves,
View view
)
Public Function NewRoomBoundaryLines (
sketchPlane As SketchPlane,
curves As CurveArray,
view As View
) As ModelCurveArray
public:
ModelCurveArray^ NewRoomBoundaryLines(
SketchPlane^ sketchPlane,
CurveArray^ curves,
View^ view
)
member NewRoomBoundaryLines :
sketchPlane : SketchPlane *
curves : CurveArray *
view : View -> ModelCurveArray
Parameters
- sketchPlane SketchPlane
- The sketch plan
- curves CurveArray
- The geometry curves on which the boundary lines are
- view View
- The View for the new Room
Return Value
ModelCurveArray
ExceptionsException | Condition |
---|
ArgumentException | Thrown if the sketch plane does not exist in the given document. |
ArgumentException | Thrown if the view does not exist in the given document. |
See Also