RailingIsValidHostForNewRailing Method |
Checks whether new railing can be created and placed on the specified host.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidHostForNewRailing(
Document document,
ElementId elementId
)
Public Shared Function IsValidHostForNewRailing (
document As Document,
elementId As ElementId
) As Boolean
public:
static bool IsValidHostForNewRailing(
Document^ document,
ElementId^ elementId
)
static member IsValidHostForNewRailing :
document : Document *
elementId : ElementId -> bool
Parameters
- document Document
-
The document.
- elementId ElementId
-
The element to check.
Return Value
Boolean
True if new railing can be created and placed on the host, False otherwise.
Exceptions
Remarks
This function will return true for stairs or ramps which can host new railings.
Stairs or ramps can host new railings only when they have no associated railing and they are not in editing mode.
See Also