Autodesk.Revit.ApplicationServices Namespace

 
Classes
 ClassDescription
Public classCode exampleApplication Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Public classControlledApplicationRepresents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.
Enumerations
 EnumerationDescription
Public enumerationLanguageType An enumerated type containing the supported Revit product languages.
Public enumerationProductTypeAn enumerated type containing the possible Revit product types.