CurveArrArray Class

An array that can contain any type of object.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCurveArrArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CurveArrArray : APIObject, 
	IEnumerable

The CurveArrArray type exposes the following members.

Constructors
 NameDescription
Public methodCurveArrArrayInitializes a new instance of the CurveArrArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyItemGets or sets an item at a specified index within the array.
Public propertySizeReturns the number of objects that are in the array.
Top
Methods
 NameDescription
Public methodAppend 
Public methodClearRemoves every item from the array, rendering it empty.
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodInsert 
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Top
See Also