CloudPoint Structure

Represents a point obtained from a Point cloud.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Autodesk.Revit.DB.PointCloudsCloudPoint

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public struct CloudPoint

The CloudPoint type exposes the following members.

Constructors
 NameDescription
Public methodCloudPoint Creates a new cloud point.
Top
Methods
 NameDescription
Public methodEqualsIndicates whether this instance and a specified object are equal.
(Inherited from ValueType)
Public methodGetHashCodeReturns the hash code for this instance.
(Inherited from ValueType)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns the fully qualified type name of this instance.
(Inherited from ValueType)
Top
Operators
 NameDescription
Public operatorStatic member(CloudPoint to XYZ) Creates an XYZ object from this point cloud.
Top
Fields
 NameDescription
Public fieldColorThe color
Public fieldXThe X coordinate
Public fieldYThe Y coordinate
Public fieldZThe Z coordinate
Top
See Also