BuiltInFailuresConstraintFailures Class

Failures about Constraint.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresConstraintFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ConstraintFailures

The BuiltInFailuresConstraintFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberUndeletedConstraints A dimension that has lock constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
Public propertyStatic memberUndeletedConstraintsEQ A dimension that has EQ constraints is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
Public propertyStatic memberUndeletedConstraintsInGroup A labeled dimension is being deleted, but the corresponding constraint belongs to a group and will not be changed. You can change it in group edit mode later.
Public propertyStatic memberUndeletedConstraintsLabel A dimension labeled by a parameter is being deleted, but the elements will still be constrained. Push "Unconstrain" to remove the constraints or "OK" to leave elements constrained..
Top
See Also