CurtainGridLineAddMullions Method |
Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementSet AddMullions(
Curve segment,
MullionType mullionType,
bool oneSegmentOnly
)
Public Function AddMullions (
segment As Curve,
mullionType As MullionType,
oneSegmentOnly As Boolean
) As ElementSet
public:
ElementSet^ AddMullions(
Curve^ segment,
MullionType^ mullionType,
bool oneSegmentOnly
)
member AddMullions :
segment : Curve *
mullionType : MullionType *
oneSegmentOnly : bool -> ElementSet
Parameters
- segment Curve
- Curve of the segment.
- mullionType MullionType
- The type of the mullion to add.
- oneSegmentOnly Boolean
- If true, add one mullion to the specified segment, otherwise add mullions to all the segments of the matching grid line.
Return Value
ElementSetIf operation succeeds, the created mullions will be returned.
Exceptions
See Also