GlobalParameterGetAffectedElements Method |
Returns all elements of which properties are driven by this global parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ISet<ElementId> GetAffectedElements()
Public Function GetAffectedElements As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetAffectedElements()
member GetAffectedElements : unit -> ISet<ElementId>
Return Value
ISetElementId
Collection of Element Ids.
Remarks
The returned collection does not include dimensions labeled by this global parameter.
To get the labeled dimensions use the
GetLabeledDimensions method.
Other global parameters that may be affected by this one (in their formulas)
are also excluded from the returned collection. To get the set of affected global
parameters use the
GetAffectedGlobalParameters method.
See Also