GlobalParameterGetLabeledDimensions Method |
Returns all dimension elements that are currently labeled by this global parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ISet<ElementId> GetLabeledDimensions()
Public Function GetLabeledDimensions As ISet(Of ElementId)
public:
ISet<ElementId^>^ GetLabeledDimensions()
member GetLabeledDimensions : unit -> ISet<ElementId>
Return Value
ISetElementId
Collection of Element Ids.
Remarks
In case of a reporting parameter the returned collection will contain
at most one element - the driving dimension, if it has been set already.
It is because reporting parameters may have only one dimension labeled.
For non-reporting parameters the set would contain all dimensions that
have been labeled by this global parameter.
See Also