PointOnEdge Class

Define a ReferencePoint relative to a referenceable edge or curve on another element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBPointElementReference
    Autodesk.Revit.DBPointOnEdge

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointOnEdge : PointElementReference

The PointOnEdge type exposes the following members.

Properties
 NameDescription
Public propertyLocationOnCurveThe point location on curve.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetEdgeReferenceGet a copy of the edge or curve reference.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetEdgeReferenceChange the edge or curve reference.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.
See Also