StairsTypeMiddleSupportType Property

The type of middle supports used in the stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId MiddleSupportType { get; set; }

Property Value

ElementId
invalidElementId if the stairs type has no middle support.
Exceptions
ExceptionCondition
ArgumentException When setting this property: supportType is not a valid middle support type.
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException When setting this property: The stairs type has no middle support so the data being set is not applicable.
See Also