GBXMLExportOptions(IListElementId, IListElementId) Constructor |
Constructs a new instance of the options used to export a mass model to gbXML.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic GBXMLExportOptions(
IList<ElementId> massZoneIds,
IList<ElementId> massIds
)
Public Sub New (
massZoneIds As IList(Of ElementId),
massIds As IList(Of ElementId)
)
public:
GBXMLExportOptions(
IList<ElementId^>^ massZoneIds,
IList<ElementId^>^ massIds
)
new :
massZoneIds : IList<ElementId> *
massIds : IList<ElementId> -> GBXMLExportOptions
Parameters
- massZoneIds IListElementId
-
Indicates the mass zones to analyze in the exported gbXML.
- massIds IListElementId
-
Indicates the masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Exceptions
See Also