GBXMLExportOptions Class

Green-Building XML Export options.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBGBXMLExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GBXMLExportOptions : IDisposable

The GBXMLExportOptions type exposes the following members.

Constructors
 NameDescription
Public methodGBXMLExportOptions Constructs a new instance of the options used to export a model in gbXML (green-building) format.
Public methodGBXMLExportOptions(IListElementId, IListElementId) Constructs a new instance of the options used to export a mass model to gbXML.
Top
Properties
 NameDescription
Public propertyEncoding The encoding options to go into the processing instruction for the exported gbXML file.
Public propertyExportAnalyticalSystems Indicates if the gbXML should contain analytical system elements (e.g., Water Loop, Air System, and Zone Equipment).
Public propertyExportEnergyModelType The energy model type from which gbXML will be exported.
Public propertyIsConceptual Indicates if the exported gbXML is based on a conceptual energy analytical model from a conceptual mass model.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the GBXMLExportOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetMassIds Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Public methodGetMassZoneIds Gets a list of mass zones to analyze in the exported gbXML.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also