ColorWithTransparency Class

Color with transparency
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBColorWithTransparency

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ColorWithTransparency : IDisposable

The ColorWithTransparency type exposes the following members.

Constructors
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ColorWithTransparency
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBlue get blue
Public methodGetColor get color
Public methodGetGreen get green
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetRed get red
Public methodGetTransparency get transparency
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetBlue set blue
Public methodSetColor set color
Public methodSetGreen set green
Public methodSetRed set red
Public methodSetTransparency set transparency
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also