gbXMLServiceType Enumeration |
This enumeration corresponds to the systemType attribute in gbXML
and is used for specifying the service for the building or space.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum gbXMLServiceType
Public Enumeration gbXMLServiceType
public enum class gbXMLServiceType
MembersMember name | Value | Description |
---|
CentralHeatingRadiators | 0 | |
CentralHeatingConvectors | 1 | |
CentralHeatingRadiantFloor | 2 | |
CentralHeatingHotAir | 3 | |
OtherRoomHeater | 4 | |
RadiantHeaterFlue | 5 | |
RadiantHeaterNoFlue | 6 | |
RadiantHeaterMultiburner | 7 | |
ForcedConvectionHeaterFlue | 8 | |
ForcedConvectionHeaterNoFlue | 9 | |
NoServiceType | -1 | |
VAVSingleDuct | 10 | |
VAVDualDuct | 11 | |
VAVIndoorPackagedCabinet | 12 | |
VAVTerminalReheat | 13 | |
FanCoilSystem | 14 | |
InductionSystem | 15 | |
ConstantVolumeFixedOA | 16 | |
ConstantVolumeVariableOA | 17 | |
ConstantVolumeTerminalReheat | 18 | |
MultizoneHotDeckColdDeck | 19 | |
ConstantVolumeDualDuct | 20 | |
RadiantCooledCeilings | 21 | |
ActiveChilledBeams | 22 | |
WaterLoopHeatPump | 23 | |
VariableRefrigerantFlow | 24 | |
SplitSystemsWithNaturalVentilation | 25 | |
SplitSystemsWithMechanicalVentilation | 26 | |
SplitSystemsWithMechanicalVentilationWithCooling | 27 | |
NoOfServiceTypes | 28 | |
See Also