ExporterIFCUtilsGetRoomBoundaryAsCurveLoopArray Method |
Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific
elements later.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<CurveLoop> GetRoomBoundaryAsCurveLoopArray(
SpatialElement spatialElement,
SpatialElementBoundaryOptions options,
bool cleanCurves
)
Public Shared Function GetRoomBoundaryAsCurveLoopArray (
spatialElement As SpatialElement,
options As SpatialElementBoundaryOptions,
cleanCurves As Boolean
) As IList(Of CurveLoop)
public:
static IList<CurveLoop^>^ GetRoomBoundaryAsCurveLoopArray(
SpatialElement^ spatialElement,
SpatialElementBoundaryOptions^ options,
bool cleanCurves
)
static member GetRoomBoundaryAsCurveLoopArray :
spatialElement : SpatialElement *
options : SpatialElementBoundaryOptions *
cleanCurves : bool -> IList<CurveLoop>
Parameters
- spatialElement SpatialElement
-
The spatial element.
- options SpatialElementBoundaryOptions
-
The options for extraction of the boundaries.
- cleanCurves Boolean
-
If true, curves will be trimmed to meet their neighbors. If false, no trimming will take place.
Return Value
IListCurveLoop
The list of CurveLoops, which could be empty if the routine is unable to get the boundary curve loops.
Exceptions
See Also