RebarSpliceUtilsGetSpliceChain Method |
Returns all the rebars that are part of a splice chain with the input rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<ElementId> GetSpliceChain(
Rebar rebar
)
Public Shared Function GetSpliceChain (
rebar As Rebar
) As IList(Of ElementId)
public:
static IList<ElementId^>^ GetSpliceChain(
Rebar^ rebar
)
static member GetSpliceChain :
rebar : Rebar -> IList<ElementId>
Parameters
- rebar Rebar
-
The input rebar.
Return Value
IListElementId
The splice chain.
Exceptions
Remarks
The elements in the output list are in exactly the same order that they are constrained to each other.
The first element in the array is the one whose Rebar Plane, Out of Plane Extent and Edge are not constrained to a rebar from the chain (second is constrained to first, third to second and so on).
The output list will also contain the input rebar id.
If the rebar is not in a splice chain the returned list will contain just one element which is the id of the input rebar.
See Also