ExporterIFCSetMaterialIdForCurrentExportState Method |
This sets the material id that is to be associated with the element in the current export state.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetMaterialIdForCurrentExportState(
ElementId elementId
)
Public Sub SetMaterialIdForCurrentExportState (
elementId As ElementId
)
public:
void SetMaterialIdForCurrentExportState(
ElementId^ elementId
)
member SetMaterialIdForCurrentExportState :
elementId : ElementId -> unit
Parameters
- elementId ElementId
-
The material id.
Exceptions
Remarks
Even though there could be several materials associated with the element (set during PushExportState()),
unless the element has support for IfcMaterialLayerSet, IFC output will include only this one.
See Also