HasNoValueFilterRule Class

Tests whether an element's parameter doesn't have a value.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterRule
    Autodesk.Revit.DBParameterValuePresenceRule
      Autodesk.Revit.DBHasNoValueFilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class HasNoValueFilterRule : ParameterValuePresenceRule

The HasNoValueFilterRule type exposes the following members.

Constructors
 NameDescription
Public methodHasNoValueFilterRule constructs an instance of HasNoValueFilterRule.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule)
Public propertyParameter The parameter which will be evaluated to pass this rule.
(Inherited from ParameterValuePresenceRule)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FilterRule)
Public methodElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also