KeyBasedTreeEntryTableReload Method |
Reloads KeyBasedTreeEntries from their currently-stored location into this KeyBasedTreeEntryTable.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExternalResourceLoadStatus Reload(
KeyBasedTreeEntriesLoadResults loadResults
)
Public Function Reload (
loadResults As KeyBasedTreeEntriesLoadResults
) As ExternalResourceLoadStatus
public:
ExternalResourceLoadStatus Reload(
KeyBasedTreeEntriesLoadResults^ loadResults
)
member Reload :
loadResults : KeyBasedTreeEntriesLoadResults -> ExternalResourceLoadStatus
Parameters
- loadResults KeyBasedTreeEntriesLoadResults
If provided, Revit will use this object to store any
errors or warnings that were encountered. Note that if the KeyBasedTreeEntries in the model are
already up to date, no errors or warnings will be added to this object.
This argument may be .
Return Value
ExternalResourceLoadStatus
Returns the outcome of the reload operation.
ExceptionsException | Condition |
---|
ModificationForbiddenException |
The document containing this KeyBasedTreeEntryTable is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document containing this KeyBasedTreeEntryTable is being loaded, or is in the midst of another
sensitive process.
|
ModificationOutsideTransactionException |
The document containing this KeyBasedTreeEntryTable has no open transaction.
|
Remarks
Revit will try to read KeyBasedTreeEntries from the resource reference stored
within the KeyBasedTreeEntryTable. If the operation fails, the table will be
unchanged.
See Also