ExternalResourceLoadStatus Enumeration

A flag to indicate the status of an ExternalResource load request.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum ExternalResourceLoadStatus
Members
Member nameValueDescription
Success0 The load operation was successful.
Failure1 The load operation failed.
Uninitialized2 The load operation is in an incomplete state. Revit will treat this result as a failure.
ResourceAlreadyCurrent3 The current version of the resource is already loaded into Revit so no changes were made to the model.
CannotFindServer4 The server identified by the ExternalResourceReference could not be found, and may not be registered.
ServerThrewException5 The server identified by the ExternalResourceReference threw an exception while attempting to load a resource.
Remarks
This flag is returned by the LoadResource method of the IExternalResourceServer class to inform callers whether the load operation succeeded, or encountered an error.
See Also