StairsGetStairsRuns Method |
Returns all the stairs run components in the stairs.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> GetStairsRuns()
Public Function GetStairsRuns As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetStairsRuns()
member GetStairsRuns : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
The stairs run components in the stairs.
Exampleprivate void AddStartandEndRisers(Stairs stairs)
{
ICollection<ElementId> runIds = stairs.GetStairsRuns();
foreach (ElementId runId in runIds)
{
StairsRun run = stairs.Document.GetElement(runId) as StairsRun;
if (null != run)
{
run.BeginsWithRiser = true;
run.EndsWithRiser = true;
}
}
}
Private Sub AddStartandEndRisers(stairs As Stairs)
Dim runIds As ICollection(Of ElementId) = stairs.GetStairsRuns()
For Each runId As ElementId In runIds
Dim run As StairsRun = TryCast(stairs.Document.GetElement(runId), StairsRun)
If run IsNot Nothing Then
run.BeginsWithRiser = True
run.EndsWithRiser = True
End If
Next
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also