ApplicationNewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) Method

Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
	XYZ location,
	FamilySymbol symbol,
	Level level,
	StructuralType structuralType
)

Parameters

location  XYZ
The physical location where the instance is to be placed.
symbol  FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level  Level
A Level object that is used as the base level for the object.
structuralType  StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstanceCreationData
See Also