Gets the filters applied to the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> GetFilters()
Public Function GetFilters As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetFilters()
member GetFilters : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
The ElementIds of the Filters.
ExceptionsException | Condition |
---|
InvalidOperationException |
The element "this View" does not belong to a project document.
-or-
The view type does not support Visibility/Graphics Overriddes.
|
Remarks
Note that this method returns filters in a set sorted according to their ids.
To get filters in the order they are applied to the view use
GetOrderedFilters.
See Also