ExporterIFCUtilsGetIFCType Method |
Note: This API is now obsolete.
Obtains the IFC type associated to the given element for the current export.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This function is deprecated in Revit 2025. Please use ExporterIFC.GetCategoryMappingTable instead.")]
public static string GetIFCType(
Element element,
ExporterIFC exporterIFC
)
<ObsoleteAttribute("This function is deprecated in Revit 2025. Please use ExporterIFC.GetCategoryMappingTable instead.")>
Public Shared Function GetIFCType (
element As Element,
exporterIFC As ExporterIFC
) As String
public:
[ObsoleteAttribute(L"This function is deprecated in Revit 2025. Please use ExporterIFC.GetCategoryMappingTable instead.")]
static String^ GetIFCType(
Element^ element,
ExporterIFC^ exporterIFC
)
[<ObsoleteAttribute("This function is deprecated in Revit 2025. Please use ExporterIFC.GetCategoryMappingTable instead.")>]
static member GetIFCType :
element : Element *
exporterIFC : ExporterIFC -> string
Parameters
- element Element
-
The element.
- exporterIFC ExporterIFC
-
The exporter.
Return Value
String
The IFC type. This is an empty string if the element should not be exported because it is not
found in the mapping file.
Exceptions
Remarks
IFC type names are affected by the user's entries in the mapping file set for a
given export operation.
See Also