ElementTypeDuplicatingEventArgs Class

The event arguments used by the ElementTypeDuplicating event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPIPreEventArgs
        Autodesk.Revit.DB.EventsRevitAPIPreDocEventArgs
          Autodesk.Revit.DB.EventsElementTypeDuplicatingEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementTypeDuplicatingEventArgs : RevitAPIPreDocEventArgs

The ElementTypeDuplicatingEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyElementTypeId The id of the ElementType to be duplicated.
Top
Methods
 NameDescription
Top
See Also