AddInCommandBinding Class

This object represents a binding between a Revit command and one or more handlers which override the behavior of the command in Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIAddInCommandBinding

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AddInCommandBinding

The AddInCommandBinding type exposes the following members.

Properties
 NameDescription
Public propertyRevitCommandIdThe Revit command Id.
Top
Methods
 NameDescription
Top
Events
 NameDescription
Public eventBeforeExecutedOccurs before the command associated with this AddInCommandBinding executes.
Public eventCanExecuteOccurs when the command associated with this AddInCommandBinding initiates a check to determine whether the command can be executed on the command target.
Public eventExecutedOccurs when the command associated with this AddInCommandBinding executes.
Top
See Also