AddInCommandBindingCanExecute Event |
Occurs when the command associated with this AddInCommandBinding initiates a check to determine whether
the command can be executed on the command target.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic event EventHandler<CanExecuteEventArgs> CanExecute
Public Event CanExecute As EventHandler(Of CanExecuteEventArgs)
public:
event EventHandler<CanExecuteEventArgs^>^ CanExecute {
void add (EventHandler<CanExecuteEventArgs^>^ value);
void remove (EventHandler<CanExecuteEventArgs^>^ value);
}
member CanExecute : IEvent<EventHandler<CanExecuteEventArgs>,
CanExecuteEventArgs>
Value
EventHandlerCanExecuteEventArgs
Remarks
This callback will be called by Revit's user interface any time there is a contextual change. Therefore, the callback
must be fast and is not permitted to be blocking in any way.
See Also