DocumentSaveToLocalProgressChangedEventArgs Class

The event arguments used during the save to local phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged].
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPISingleEventArgs
        Autodesk.Revit.DB.EventsWorksharedOperationProgressChangedEventArgs
          Autodesk.Revit.DB.EventsDocumentSaveToLocalProgressChangedEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentSaveToLocalProgressChangedEventArgs : WorksharedOperationProgressChangedEventArgs

The DocumentSaveToLocalProgressChangedEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyBeforeSaveToCentral True if the "save to local" operation is occurring before "save to central"; false if after.
Public propertyFinishedStreams The number of streams finished since the last time this event was raised.
Public propertySaveToLocalFinished Indicates if the current "save to local" operation has finished.
Public propertyTotalStreams The total expected number of streams to save to local.
Top
Methods
 NameDescription
Top
Remarks
It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time. Name correction - it is renamed from 'DocumentSaveToLocalProgessChangedEventArgs' released since 2017 Subscription Update.
See Also