DocumentSaveToLocalProgressChangedEventArgs Class

The event arguments used during the save to local phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged].
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPISingleEventArgs
        Autodesk.Revit.DB.EventsWorksharedOperationProgressChangedEventArgs
          Autodesk.Revit.DB.EventsDocumentSaveToLocalProgressChangedEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentSaveToLocalProgressChangedEventArgs : WorksharedOperationProgressChangedEventArgs

The DocumentSaveToLocalProgressChangedEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyBeforeSaveToCentral True if the "save to local" operation is occurring before "save to central"; false if after.
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs)
Public propertyFinishedStreams The number of streams finished since the last time this event was raised.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs)
Public propertyLocation Full path of the central model which is to be operated.
(Inherited from WorksharedOperationProgressChangedEventArgs)
Public propertySaveToLocalFinished Indicates if the current "save to local" operation has finished.
Public propertyStatus Gets API event status, reflect current operation execution status.
(Inherited from WorksharedOperationProgressChangedEventArgs)
Public propertyTotalStreams The total expected number of streams to save to local.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RevitAPIEventArgs)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time. Name correction - it is renamed from 'DocumentSaveToLocalProgessChangedEventArgs' released since 2017 Subscription Update.
See Also