RebarContainerIterator Class

An iterator to a Rebar Container.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureRebarContainerIterator

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarContainerIterator : IEnumerator<RebarContainerItem>

The RebarContainerIterator type exposes the following members.

Properties
 NameDescription
Public propertyCurrentGets the item at the current position of the iterator.
Protected propertyCurrentObject 
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RebarContainerIterator
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodMoveNext Increments the iterator to the next item.
Public methodReset Resets the iterator to the initial state.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also