RebarContainerIterator Class

An iterator to a Rebar Container.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.StructureRebarContainerIterator

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarContainerIterator : IEnumerator<RebarContainerItem>

The RebarContainerIterator type exposes the following members.

Properties
 NameDescription
Public propertyCurrentGets the item at the current position of the iterator.
Protected propertyCurrentObject 
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the RebarContainerIterator
Public methodMoveNext Increments the iterator to the next item.
Public methodReset Resets the iterator to the initial state.
Top
See Also