RPCNode Class

This class represents an RPC content in a model-exporting process.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRenderNode
    Autodesk.Revit.DBContentNode
      Autodesk.Revit.DBRPCNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RPCNode : ContentNode

The RPCNode type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode)
Public propertyNodeName A readable name of the output node.
(Inherited from RenderNode)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RenderNode)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetAsset Returns an an instance of an Asset object, which contains definitions of the content node.
(Inherited from ContentNode)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTransform A transformation matrix associated with the node.
(Inherited from ContentNode)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
See also: OnRPC(RPCNode).
See Also