FaceBasedPlacementType Enumeration |
This enumerated type specifies options available for placement of a face-based family instance.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum FaceBasedPlacementType
Public Enumeration FaceBasedPlacementType
public enum class FaceBasedPlacementType
type FaceBasedPlacementType
MembersMember name | Value | Description |
---|
Default | 0 |
Placement the instance which is not face-based.
|
PlaceOnVerticalFace | 1 |
Placement on a vertical face.
|
PlaceOnFace | 2 |
Placement on a selected face from existing geometry.
|
PlaceOnWorkPlane | 3 |
Placement on current workplane.
|
See Also