Primary |
The PrimaryDesignOptionMemberFilter type exposes the following members.
Name | Description | |
---|---|---|
![]() | PrimaryDesignOptionMemberFilter | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set. |
![]() | PrimaryDesignOptionMemberFilter(Boolean) | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set. |
Name | Description | |
---|---|---|
![]() | Inverted |
True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected,
and elements that would normally be rejected will be accepted.
(Inherited from ElementFilter) |
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ElementFilter) |
Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ElementFilter) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | PassesFilter(Element) |
Applies the filter to a given element.
(Inherited from ElementFilter) |
![]() | PassesFilter(Document, ElementId) |
Applies the filter to a given element.
(Inherited from ElementFilter) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |
// Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options PrimaryDesignOptionMemberFilter filter = new PrimaryDesignOptionMemberFilter(); // Apply the filter to the elements in the active document // Use shortcut command OfClass() to only find wall instances FilteredElementCollector collector = new FilteredElementCollector(document); ICollection<Element> wallsOfPrimaryOpt = collector.OfClass(typeof(Wall)).WherePasses(filter).ToElements(); // Find walls not contained within primary design options: Use inverted filter to match walls PrimaryDesignOptionMemberFilter notPrimaryOptFilter = new PrimaryDesignOptionMemberFilter(true); // inverted filter collector = new FilteredElementCollector(document); ICollection<Element> notPrimaryDesignOptFounds = collector.OfClass(typeof(Wall)).WherePasses(notPrimaryOptFilter).ToElements();