MechanicalUtilsConnectDuctPlaceholdersAtElbow(Document, ElementId, ElementId) Method |
Connects a pair of placeholders that can intersect in an Elbow connection.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool ConnectDuctPlaceholdersAtElbow(
Document document,
ElementId placeholder1Id,
ElementId placeholder2Id
)
Public Shared Function ConnectDuctPlaceholdersAtElbow (
document As Document,
placeholder1Id As ElementId,
placeholder2Id As ElementId
) As Boolean
public:
static bool ConnectDuctPlaceholdersAtElbow(
Document^ document,
ElementId^ placeholder1Id,
ElementId^ placeholder2Id
)
static member ConnectDuctPlaceholdersAtElbow :
document : Document *
placeholder1Id : ElementId *
placeholder2Id : ElementId -> bool
Parameters
- document Document
-
The document.
- placeholder1Id ElementId
-
The element id of the first duct placeholder.
- placeholder2Id ElementId
-
The element id of the second duct placeholder.
Return Value
Boolean
True if connection succeeds, false otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
The element id placeholder1Id is not duct placeholder.
-or-
The element id placeholder2Id is not duct placeholder.
-or-
The elements belong to different types of system.
-or-
The curve placeholder1Id and placeholder2Id are not physically connected.
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
The placeholders must meet at a physical end connection.
If connection fails, the placeholders cannot be physically connected.
See Also