General utility methods in the Autodesk Revit MEP product.
Inheritance Hierarchy Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static class MechanicalUtils
Public NotInheritable Class MechanicalUtils
public ref class MechanicalUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MechanicalUtils = class end
The MechanicalUtils type exposes the following members.
Methods | Name | Description |
---|
  | BreakCurve |
Breaks the duct curve into two parts at the given position.
|
  | ConnectAirTerminalOnDuct |
Connects an air terminal to a duct directly (without the need for a tee or takeoff).
|
  | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId) |
Connects a pair of placeholders that can intersect in a Cross connection.
|
  | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId, ElementId) |
Connects a trio of placeholders that can intersect in a Cross connection.
|
  | ConnectDuctPlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) |
Connects a group of placeholders that can intersect in a Cross connection.
|
   | ConnectDuctPlaceholdersAtElbow(Document, Connector, Connector) |
Connects a pair of placeholders that can intersect in an Elbow connection.
|
  | ConnectDuctPlaceholdersAtElbow(Document, ElementId, ElementId) |
Connects a pair of placeholders that can intersect in an Elbow connection.
|
  | ConnectDuctPlaceholdersAtTee(Document, ElementId, ElementId) |
Connects a pair of placeholders that can intersect in a Tee connection.
|
  | ConnectDuctPlaceholdersAtTee(Document, Connector, Connector, Connector) |
Connects a trio of placeholders that can intersect in a Tee connection.
|
  | ConvertDuctPlaceholders |
Converts a collection of duct placeholder elements into duct elements.
|
Top
See Also